XBMC Export Plugin (v0.88)

Additional plug-ins for the program.
CanadianPilgrim
Extra
Posts: 36
Joined: Tue Jan 17, 2012 7:22 am

Re: XBMC Export Plugin (v0.88)

Post by CanadianPilgrim » Sat Jan 28, 2012 11:14 pm

Nope. Did not know about the "C" shortcut, but found the same menu by "right-click" on the mouse. There is no response to the "Movie Information" command.

Remember, this is from the list I exported after you modified 8.7 to add the ability to export movies with a pathed video filename? Does that have something to do with it?

User avatar
JeF
Black Belt Squirrel
Posts: 1175
Joined: Fri Feb 20, 2009 3:34 pm
Location: France

Re: XBMC Export Plugin (v0.88)

Post by JeF » Sun Jan 29, 2012 9:26 am

CanadianPilgrim wrote:Nope. Did not know about the "C" shortcut, but found the same menu by "right-click" on the mouse. There is no response to the "Movie Information" command.
Remember, this is from the list I exported after you modified 8.7 to add the ability to export movies with a pathed video filename? Does that have something to do with it?
Is the 'special' folder still viewable/reachable from xbmc ?
Does it still contain all files (nfo and so...) ?
Did you try to manually rescan that source in xbmc ?
Please also check if that source is of 'movie' type.
(i have no pb with that feature)
JeF

CanadianPilgrim
Extra
Posts: 36
Joined: Tue Jan 17, 2012 7:22 am

Re: XBMC Export Plugin (v0.88)

Post by CanadianPilgrim » Sun Jan 29, 2012 10:41 pm

JeF,

If I ever get to France, or you ever get to central Canada, I will buy you a great meal! Your tips and advise and willingness to help have solved my issues and made me glad for the time and effort I put into MovieNizer and the XBMC Export! :lol:

Owen

CanadianPilgrim
Extra
Posts: 36
Joined: Tue Jan 17, 2012 7:22 am

Re: XBMC Export Plugin (v0.88)

Post by CanadianPilgrim » Sat Feb 04, 2012 5:20 pm

JeF,

Would you have a look at my post in the Bugs forum? Title MN Update Causing Problems. Version 5.1 was updated subsequent to my work with you on the XBMC export. Would the changes to the XBMC Plubin adversely affect sqlite3.dll? :? This problem has completely hung MN. That is, I cannot any changes or additions because they will not keep.

Owen

User avatar
JeF
Black Belt Squirrel
Posts: 1175
Joined: Fri Feb 20, 2009 3:34 pm
Location: France

Re: XBMC Export Plugin (v0.88)

Post by JeF » Sun Feb 05, 2012 9:31 am

CanadianPilgrim wrote:Version 5.1 was updated subsequent to my work with you on the XBMC export. Would the changes to the XBMC Plubin adversely affect sqlite3.dll? :? This problem has completely hung MN. That is, I cannot any changes or additions because they will not keep.
The plugin si an additional dll file which doesn't alter main program (nor sqlite.dll). Just remove all XBMC* files from 'plugins' subfolder and check if the issue is still there (please give it several tries).
If issue isn't there anymore (should indicate plugin is invovled), restore XBMC* files into 'plugins' subfolder and check again : rising the issue ?
If so, could you upload your db (zipped *.dmo file only) to a sharing file server an give a step by step description on how to get the issue ? I'll then could check if plugin is involved or not.
JeF

CanadianPilgrim
Extra
Posts: 36
Joined: Tue Jan 17, 2012 7:22 am

Re: XBMC Export Plugin (v0.88)

Post by CanadianPilgrim » Sun Feb 05, 2012 8:03 pm

JeF wrote:Just remove all XBMC* files from 'plugins' subfolder and check if the issue is still there (please give it several tries)...
JeF
I did what you said. 5 or 6 tests in total. There are no more sqlite.dll errors and the changes are being saved. The only thing that is not working is the movie information downloads, that is the 200 Timeout error keeps recurring; however, that may be an unrelated problem. I have not tried reinstalling the XBMC Export PlugIn.

By the way, MovieNizer now insists on running with Administrator privileges?

So what now?

P.S. Post March 3, 2012. Status is still the same. XBMC Export Plug In is the problem causing the sqlite error, BUT please do not undo the modifications which created a dummy path for non-pathed files! HERE IS MY WORKAROUND: I have created a separate MN directory for the 4 XBMC Export files. When I have to export, I move them to the plugins directory, restart MN, Export, then close MN and move the 4 files back again. This is a minor inconvenience.

CanadianPilgrim
Extra
Posts: 36
Joined: Tue Jan 17, 2012 7:22 am

Re: XBMC Export Plugin (v0.88)

Post by CanadianPilgrim » Wed Jan 16, 2013 5:18 am

Been awhile, but I am back. I see this forum has become quite popular in terms of views. :D

So it was time for me to refresh my beloved XBMC database, and I was disappointed to learn that it seems not to work with MN version 5.5. I followed the same procedure as outlined in my last post to prepare for the export by moving the XBMC Export files (v.0.88) into the Plugins directory and restarting the program.

I get the same .dll error as before :( (was hoping you guys would have fixed that and incited me to the v. 6 upgrade), but, when MN is running, I now get unintellible characters in the last line of the drop down menu. When I select that option, it brings up the XBMC executable, it returns errors saying, first, that the selected file is not a MN file and then reports an access violation (x2). When the export screen then appears, it lists the correct path and filename to my MN file, but shows no files for export.

Please tell me you have not abandoned the XBMC export plugin.

User avatar
JeF
Black Belt Squirrel
Posts: 1175
Joined: Fri Feb 20, 2009 3:34 pm
Location: France

Re: XBMC Export Plugin (v0.88)

Post by JeF » Wed Jan 16, 2013 7:57 am

Hi Owen,
CanadianPilgrim wrote:Please tell me you have not abandoned the XBMC export plugin.
Well, there's been quite a while since i last worked on that beta plugin (this was my first plugin as a beginner exercise...).
However, as i upgraded other plugins for Movienizer 5.5+, 6.0+ (Extra Queries and Attributes Renamer), i will try to upgrade this one if possible (not only an upgrade to new dev platform but also things to fix i don't currently know if possible and how).
When it's ready, i will start a new thread because this beta is no more compatible with Movienizer 5.5+ as dev platform has changed (for full unicode support and other purposes).
So, please be patient, i'll do my best to release asap but i've not much time to spend on Mnz dev and i've currently other things under dev having higher priority.
;)
JeF

CanadianPilgrim
Extra
Posts: 36
Joined: Tue Jan 17, 2012 7:22 am

Re: XBMC Export Plugin (v0.88)

Post by CanadianPilgrim » Wed Jan 16, 2013 11:41 pm

Thanks JeF!

Please also recall that invaluable modification you made to allow for export of movie titles and descriptions where there was no path to a video file. Would like to see that one continued.

Fisty
Passerby
Posts: 2
Joined: Mon Feb 18, 2013 6:25 pm

Re: XBMC Export Plugin (v0.88)

Post by Fisty » Mon Feb 18, 2013 6:41 pm

dosen't work for me
tested with Movienizer v5.5 and v6.0 on Windows 7 Ultimate 64bit
open plugin
Image
select db
Image

Post Reply